Jump to content

Recommended Posts

I gave up on ever seeing the welcome package. But, I do have a couple warranty questions for you. We bought our R227 last summer,  it's a 2017. Since day 1 I've received an error message on my garmin that says the transducer is disconnected. I have a thru hull transducer. I called garmin and they said it is an install issue. My dealer says I have to bring the boat to them... which is much easier said than done since their not near me and I don't have a trailer. I keep it in a dry storage year round. I've also noticed that the panel around my gauges is bubbling up. Can you direct me to someone at robalo I could speak to about these issues? Thank you so much. I'll send you a pic of the bubbling.

Share this post


Link to post
Share on other sites

In my experience, only the dealer can or will help you. I'm not sure what your Garmin issue is, but I had to configure mine for the correct transducer, the dealer didn't. I had paint bubbling around the gauges myself. I sanded it down and painted it. The screws on the gauge panel were corroding and I replaced them with 316 stainless screws and painted them at the same time. If your panel bubbling is like mine, it appears the screws had a reaction with the aluminum and caused the bubbling.

My boat was dry stored. My original dealer had offered to put the boat on his trailer for $150 to do warranty work. Before I had any warranty work needing that dealer, Robalo changed dealers. I then had a one way 4 hour trip by boat to the new dealer. Luckily I only had to take it in once to the dealer.

Share this post


Link to post
Share on other sites

We're having an in water boat show here tomorrow. I hope to corner someone from garmin, robalo and my dealer to get some answers. Much tougher to deal with than a car warranty. I can't even get anyone to say whether my boat is under warranty or not. It's a 2017 R227 with 50 hours on it. By the way, someone I talked to at the dealership recommends I bypass the thru hull transducer with an external mounted one. Don't think i'll be doing that...

Share this post


Link to post
Share on other sites

I have found the Garmin support team to be good.  Only on one occasion did I feel I was not getting the correct answer.  I then waited a day and called back and got someone else that solve the issue.  

The first thing you need to do is update the software on your Garmin unit.  It is easy to do.  YouTube has videos on this.  After you updated the software, see if the problem continues.  If it continues, reset the unit to factory defaults.  If your transponder is an Airmar or Garmin transponder, it should work fine.  

Share this post


Link to post
Share on other sites

Your Robalo warranty is serviced by the dealer.  Robalo won't be a your show, only dealer(s).  Your dealer has to provide your warranty.  Don't know who "anyone" is, but your 2017 has a 5 year warranty on everything but the hull, which is a 10 year warranty.  And the engine warranty is separate.

As to the Garmin message, I assume you've checked that the port on your Garmin labeled "Sonar" has a cord plugged into it?  I'd advise not updating any software at this point, until you perform some basic checking.  Firmware should not impact the unit sensing the transducer.

Your dealership was required to prep the boat upon delivery, and complete a checklist, which you should have signed.  I wouldn't have left the dealer without verifying that everything worked and that you knew how to operate everything.  

Lastly, the answers you're getting are from customers just like you.  Robalo doesn't maintain a presence on their own forum, although a Robalo regional rep posts from time to time.  

Share this post


Link to post
Share on other sites

Since the dealer that you purchased the boat from isn't convenient for you, try to coordinate between them and someone local to do the warranty work.

Share this post


Link to post
Share on other sites

Is it posible that you put he boat out of the water and pay the travel time for the Dealer's mechanic? I think it is a solution. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×